Page 3 of 4

Same problem with Newly purchaced Linplug RMV. I'm running PT7.4 - VST to RTAS V2.1

Posted: Tue Jan 06, 2009 8:54 pm
by mattmartone
dj fade wrote:also noticed altiverb will wrap, but freezes pro tools everytime i try to load it as an insert. anyone else had issues with altiverb?

Same problem with Newly purchased Linplug RMV. I'm running PT7.4 - VST to RTAS V2.1 with 68 other vst isntruments & fx all of which give me no problems. Linplug RMV is detected & wrapped fine, but when I open as an insert in PT the GUI appears for a split second and then PT shuts down with no error messages. I guess it's either protools or linplug that is causing the conflict. I guess I will go for the refund option as they (Peter @ Linplug) were kind enough to offer it. What a shame. It looked to be a really useful plugin amd I was excited to use it. Maybe I should upgrade to PT8 and see if that fixes it. haha

Posted: Fri Jan 09, 2009 4:55 pm
by Angus_FX
re_mute - no, there's simply nothing we can do. The VST devs have all the info they need, if they refuse to do anything with it we can't force them.

Sonic Charge and AD are usually pretty good about fixing this kind of thing, and RMV is brand new, probably just needs some debugging still.

Posted: Sat Jan 17, 2009 9:38 pm
by Gridden
None of Quik Quak's plugs work and the new 2C-Aether reverb -
has the frozen GUI problem.

Posted: Sat Jan 24, 2009 2:03 pm
by guysigs
BazzISM 2.00 doesn't work

Mac Os X 10.5 Pro Tools 8

VST to RTAS a bluff?

Posted: Sun Jan 25, 2009 2:09 pm
by fransmo
After a lot of thought I´ve finally downloaded AND PAID for VST to RTAS. This software seems to be nothing but a bluff. What chance of refound is there for the customer? Probably nada! One should open a lawcase against this sort of trading, where a customer has absolutely no guarantee that the item he buys will ever work. It´s just a chance. And software manufacturers accuse filesharers of being criminals! One might as well throw money in the sea, than buying software from companies like these!

I run a new imac/leopard/2gb/m-audio fw410/ProTools 8. I also own Steinberg Halion symphony orchestra as well a Groove Agent 3 and like them and would like to use them with ProTools. That is why I bought the adapter. These are well known and reknowned plugs. No one of the will open in VST to RTAS!!!. This software seems lika a joke to me.

From what I see on your site you obviously have not done much updating on this adapter since 2006. I M SORRY to sound so angry, but I really am. If this doesnt work with Steinbergs own plugs - then with what is it supposed to work?

STAY AWAY from FXPANSION!!! :evil:

Posted: Sun Jan 25, 2009 2:36 pm
by Angus_FX
Actually, our refund policy is that if it doesn't work for what you're looking to do, after all avenues of tech support have been exhausted (i.e. our tech guys have been given a fair chance to get you up and running), you can ask for your money back. So that's something to bear in mind.

Secondly - VST has never been the most well-defined standard, and unfortunately it has not always been best looked after by its erstwhile maintainer, Steinberg. My impression is that the engineers there mean well, but the management won't give them the resources or flexibility to do things properly, resulting in the ill-thought-out 2.4 update and the widely rejected VST3. As such it's always going to be somewhat of a hit-and-miss, use-at-your-own-risk scenario with any host and plug-ins, and VST-RTAS is no exception. Coming from the high-end and vendor-controlled world of Pro Tools, that can be a bit of a shock, but let me ask - do you seriously think Digidesign doesn't have the resources to support VST themselves, or just acquire FXpansion outright, if they wanted to do so?

As to your specific enquiry re the Steinberg plug-ins - can you give me more info as to how they 'fail to open' - do they not wrap at the config stage, or do they crash, or not load in Pro Tools, etc.? Also, is your HALion Symphony the latest Universal Binary version? There are some older versions of that plug-in which are not UniBin and so won't work on an Intel Mac.

We haven't updated the wrapper much since '06, it's true - but nor has the VST2 spec or PT itself (at least until the brand new v8) changed in that time, so why would we be expected to? If it becomes apparent that an update is needed for PT8, we'll release one, but for now that does not seem to be the case although we're keeping an eye. It's early days yet for PT8, and it may take some time for the full picture to emerge on that front.

VST to RTAS a bluff? cont.

Posted: Sun Jan 25, 2009 4:23 pm
by fransmo
What happens is I get the message:probing file....----"HALSymphOrch could not be wrapped" over and over again please consult the VST wrapped...+ the same with Groove agent 3 (plus I get message The programme VST to RTAS has unexpectedly terminated - allthough I click to ignore that).

So I never get a chance even to get HSO or Groove agent into PT.
Yes I use the latest update of both HSO and GA3.

If this shows to be impossible to get to work, I surely would be happy for a refound, since this was the sole and only reason I bought VST to RTAS adapter. / Frans

Another silly thing is that one cannot even adjust the window of the adapter so as to be able to read the whole messages, at least I can´t.

Posted: Sun Jan 25, 2009 4:34 pm
by Angus_FX

Have you succesfully run those plugins in any other host on that computer to make sure they're properly installed and authorised first.? Sometimes that does the trick.

bluff? cont.

Posted: Sun Jan 25, 2009 5:38 pm
by fransmo
Yes, I use them in Cubase 4 as well as Logic Studio 8 (through VST to AU adapter!) on the same computer and they work well. All software are registered/authorized. No cracked versions. /Frans :cry:

Posted: Mon Jan 26, 2009 2:05 am
by Angus_FX
OK - rather than take this thread further off topic, can you please contact our tech support crew via the contact form on the web site and tell them exactly what you've told me (copy and paste would do fine). You will need to send them the wrapper's Vstprobe.log file also, which contains information about what happened during scanning. It's quite weird that they would work in VST-AU and not VST-RTAS, as the probe part of the application is almost identical.


Posted: Mon Jan 26, 2009 10:04 pm
by fransmo
OK I´ve done that now and we´ll see whats happening. /Frans

No response from FXpansion support

Posted: Sun Feb 01, 2009 10:22 am
by fransmo
Hi Angus!
As I said I did what you recommended me to do: I sent our discussion to the FXpansion support through the form on your site, tpgether with the log file. I have still not even got a response from the support. What am I going to do, call the police or start a law suit (there might be a case for it)? Frans :evil:

Posted: Thu Mar 05, 2009 3:38 pm
by Gridden
"QuikQuak has released updates for all its plug-ins to fix VST-RTAS wrapper compatibility."

Tone2 Gladiator

Posted: Sat Mar 14, 2009 3:24 am
by dxtrprpur
Tone2 Gladiator (demo) : GUI does not respond.

Intel Mac / Mac OS 10.4.9 / Pro Tools LE 7.3.1 cs7

Posted: Sun May 10, 2009 12:07 pm
by TCDetroit
Camel: Alchemy & VST wrapper crashing....
PT's 8cs2 OS 10.5.6 PPC
Need to use Bidule

Process: Pro Tools HD [379]
Path: /Applications/Digidesign/Pro Tools/Pro Tools Tools HD
Identifier: com.digidesign.ProToolsHD
Version: 8.0.0cs2 (8.0.0f323)
Code Type: PPC (Native)
Parent Process: launchd [103]

Date/Time: 2009-05-10 07:59:08.736 -0400
OS Version: Mac OS X 10.5.6 (9G55)
Report Version: 6

Exception Codes: KERN_INVALID_ADDRESS at 0x00000000805e0038
Crashed Thread: 0

Thread 0 Crashed:
0 ??? 0x805e0038 0 + 2153644088
1 com.fxpansion.vst2rtas.Alchemy 0x3d915f9c CloseMachOPlugIn + 89680
2 com.fxpansion.vst2rtas.Alchemy 0x3d8f5b90 0x3d8f3000 + 11152
3 com.fxpansion.vst2rtas.Alchemy 0x3d915e30 CloseMachOPlugIn + 89316
4 com.fxpansion.vst2rtas.Alchemy 0x3d8f5b48 0x3d8f3000 + 11080
5 com.fxpansion.vst2rtas.Alchemy 0x3d92f51c CloseMachOPlugIn + 193488
6 com.fxpansion.vst2rtas.Alchemy 0x3d90c810 CloseMachOPlugIn + 50884
7 com.fxpansion.vst2rtas.Alchemy 0x3d938690 CloseMachOPlugIn + 230724
8 com.fxpansion.vst2rtas.Alchemy 0x3d8fc0fc 0x3d8f3000 + 37116
9 com.fxpansion.vst2rtas.Alchemy 0x3d98d978 operator delete(void*, void*) + 20004
10 com.digidesign.framework.DAE 0x03ea2b64 FicGetApplicationInterface + 117420
11 com.digidesign.framework.DAE 0x03fa92c0 FicPlugInEvent + 236
12 ...gidesign.framework.ProTools 0x01ffa3e8 Cmn_TypedException<Cmn_ANSIExceptionData>::Cmn_TypedException(Cmn_TypedExceptionCode<Cmn_ANSIExceptionData> const&, Cmn_ANSIExceptionData const&, Cmn_StackDump*) + 1658228
13 ...gidesign.framework.ProTools 0x01ffa798 Cmn_TypedException<Cmn_ANSIExceptionData>::Cmn_TypedException(Cmn_TypedExceptionCode<Cmn_ANSIExceptionData> const&, Cmn_ANSIExceptionData const&, Cmn_StackDump*) + 1659172
14 ...gidesign.framework.ProTools 0x02184d00 Cmn_TypedException<L10N_ExceptionData>::Cmn_TypedException(Cmn_TypedExceptionCode<L10N_ExceptionData> const&, L10N_ExceptionData const&, Cmn_StackDump*) + 913788
15 ...gidesign.framework.ProTools 0x02153b78 Cmn_TypedException<L10N_ExceptionData>::Cmn_TypedException(Cmn_TypedExceptionCode<L10N_ExceptionData> const&, L10N_ExceptionData const&, Cmn_StackDump*) + 712692
16 com.digidesign.framework.DFW 0x00802df4 DFW_Timers::LockedCallbackTimerProc::operator()(void*) + 88
17 com.digidesign.framework.DFW 0x00800860 DFW_Timers::CallbackTimerManager::MasterCallback(void*) + 88
18 com.digidesign.framework.DFW 0x007fef58 bool DFW_Event2MacOSEvent::SetDFWProperty<unsigned long, 1802334052l, 1819242087l, DFW_KeyModifiersProxy, 1096900971l>(OpaqueEventRef const*, DFW_EventRef) + 1956
19 com.digidesign.framework.DFW 0x00817524 TC::Open() + 17060
20 0x9431b9dc CFRunLoopRunSpecific + 2972
21 0x953d0bc8 RunCurrentEventLoopInMode + 268
22 0x953d09ec ReceiveNextEventCommon + 416
23 0x9542ea18 RunApplicationEventLoop + 152
24 com.digidesign.framework.DFW 0x007f3e10 DFW_EventLoop::RunApplicationEventLoop() + 16
25 com.digidesign.framework.DFW 0x007848c8 TApplication::Run() + 64
26 ...gidesign.framework.ProTools 0x027d45dc LaunchProTools + 1756
27 com.digidesign.ProToolsHD 0x00009c64 0x1000 + 35940
28 com.digidesign.ProToolsHD 0x00003624 0x1000 + 9764
29 com.digidesign.ProToolsHD 0x00003328 0x1000 + 9000
30 ??? 0000000000 0 + 0