MIDI Channels that Etch responds to... - Fxpansion.com

Forum

FXpansion Forum

MIDI Channels that Etch responds to...

Support forum for Etch VST/AU/RTAS

Moderators: Drew_fx, Mully_FX, mayur_FX, Angus_FX, Andreas_FX, Rory_FX, Rhi_FX, Paul_fx, clare_fx, SKoT_FX, Steve_FX, Moderators

copacetic
Posts: 1
Joined: Sun Jul 08, 2012 2:40 pm

MIDI Channels that Etch responds to...

Postby copacetic » Fri Jul 27, 2012 8:35 pm

I've just started using Etch recently, so I may be missing something elementary, but there is something that is causing me some irritation, although I love Etch itself.

I'm using Reaper as a DAW, if that's relevant.

Right, so I am using Etch as as insert on the same track as the instrument. Generally, I just have one instrument per track, and so 90% of the time this is happening on channel one. Because Etch receives messages on channel one, this causes LFO 1 to go mad, which is highly annoying and renders things unusable.

Of course, as mentioned in another thread, I can send to my instruments via other MIDI channels, and so not talk to Etch, and while this does indeed work, it's a rather odious workaround, as then every time I want to work on the MIDI track of an instrument, I have to change to a channel other than the default of 1.

So, what am I asking for?

An option in the Etch preferences, which will globally (for all instances of etch, and any future instances) set which MIDI channels Etch receives instructions from (instead of it always defaulting to 1-4).

Does this make sense? Useful?

***

The other thing is this:

I am using etch, as described above, and I am using MIDI to change the rate of LFO 1 (which is in turn controlling the filter cutoff).

I do not want the LFO to modulate the source all the time, I only want it to modulate the filter freq when there is a MIDI note telling it to do so. As far as I can tell what happens now, is that the LFO rate stays on whatever the last MIDI instructed it to run at.

What I'd expect (prefer) it do do is in the absence of a MIDI note, default to no modulation. Does this make sense? I'm not sure if this would be desired behaviour for anyone else?

Anyway, thanks for listening, I'm open to advice!

:)

***

*Edit*

I must have been fast asleep when I posted this, as far as I can tell, this won't help.

I'll ruminate and update.

Damnit.

Drew_fx
Posts: 3827
Joined: Fri Jul 21, 2006 5:32 pm
Location: London, UK

Postby Drew_fx » Mon Jul 30, 2012 12:14 pm

Why don't you just route the output of the instrument to another track, and have Etch on that track - like a bus in Pro Tools or Live, etc...

Or you could insert an IX Midi Router plugin AFTER your instrument plugin, and change the output channel to 16 - that way Etch wont respond to those midi notes.

New Loops
Posts: 10
Joined: Fri Aug 03, 2012 9:43 pm

Postby New Loops » Mon Mar 04, 2013 1:05 pm

Actually Etch in Reaper is causing me the same problems. All the lower midi notes change Etch's settings. Isn't there a way to turn this off? I already do complex routing and don't want to route more as a workaround.

Thanks.

RenLB
Posts: 24
Joined: Mon Nov 22, 2010 12:38 pm

Postby RenLB » Mon Apr 01, 2013 7:28 pm

Just wanna say THANKS to Drew_fx for pointing out that IX MIDI Router i'd probably never find that little gem on my own! It solves the problem and also has a transposer which is really cool for other things.

Damn, i use Reaper since 2008 and i lost count how many times i faced an "impossible" situation but in the end someone always manage to find a solution for every problem (even the crazy ones!) no matter how "impossible" it seems ahahaha it's incredible.

I gotta give more love to those JS effects and get familiar with them A.S.A.P!


Return to “Etch”

Who is online

Users browsing this forum: No registered users and 2 guests