Downloading an older version of ETCH? - Fxpansion.com

Forum

FXpansion Forum

Downloading an older version of ETCH?

Support forum for Etch VST/AU/RTAS

Moderators: Drew_fx, Mully_FX, mayur_FX, Angus_FX, Andreas_FX, Rory_FX, Rhi_FX, Paul_fx, clare_fx, SKoT_FX, Steve_FX, Moderators

noeqplease
Posts: 7
Joined: Fri Feb 25, 2011 4:26 am

Downloading an older version of ETCH?

Postby noeqplease » Sun Oct 18, 2015 6:25 pm

Hi,

I am trying to figure out if the latest version of ETCH, which does NOT work on my computer,
is the culprit, or if it is a license manager software issue.

BUT:

I cannot download any version other than 1.2.0.7

On the other three plug ins I own, Bloom, Maul, and Tremor, there is a download link to the previous version.

WHY NOT FOR ETCH AS WELL?!?

Yes, I am yelling, so sue me. The license manager says it is authorized, Pro Tools HD10.3.10 says NOT.

Image

Image

Return to “Etch”

Who is online

Users browsing this forum: No registered users and 2 guests