Page 1 of 1

MIDI learn issue

Posted: Sun Mar 03, 2013 8:39 pm
by __BT41__
Using an Oxygen49 controller in Logic 9.

I can control other effects parameters (like Waves) fine.

I can control Tremor and DCAM Synth parameters fine.

However, I cannot control Fxpansion effects (like Bloom and Etch parameters). Does not work if I try the MIDI learn function within, or if I assign via Logic's controller assignments window.

Any ideas?

Thanks.

Posted: Mon Mar 04, 2013 10:34 am
by Rory_FX
Hi,

I believe Logic cannot sent MIDI to normal insert effects. Instead you have to setup the effect as the input on an Instrument channel from the "AU MIDI controlled effects" submenu and then use the sidechain to send the audio from another channel through it.

Posted: Mon Mar 04, 2013 12:38 pm
by __BT41__
Hi,

No, I can definitely send MIDI to other insert effects. I tried both Logic effects and some Waves effects.

Only the Fxpansion ones do not work (Etch and Bloom).

Thx.

Posted: Mon Mar 04, 2013 2:30 pm
by Rory_FX
Can you explain how? As far as I'm aware it's impossible to send MIDI to insert effects in any way other than the way I described.

Posted: Mon Mar 04, 2013 2:36 pm
by __BT41__
Create a channel with some effect insert. Open Logic's controller assignments window. Put it in learn mode. Click a control in the effect. The name of that control will appear in the controller assignments window. Then I move a knob or slider on my Oxygen49. That registers in the controller assignments window. Then I click learn mode again. And now the knob (or slider) controls the control in the effect that I assigned it to.

Posted: Mon Mar 04, 2013 3:11 pm
by Rory_FX
Thanks (Logic's not my 1st DAW). I think I've reproduced the problem here. Oddly it seems to work fine if inserted on an Instrument channel, but not on an Audio channel.

Looking into it...

Posted: Mon Mar 04, 2013 3:15 pm
by __BT41__
No worries, thanks for the quick response.

Interesting... I am pretty sure that I have this problem on an instrument channel - I will double check that later.

Thanks,
B

Posted: Mon Mar 04, 2013 3:33 pm
by Rory_FX
OK, problem solved I think.

You have to have some audio running on the track to make it work (import some audio and press play, then try the MIDI learn).

It's a Logic "featurebug" to do with AU Music Effects which handle their own MIDI (ig. Maul/Bloom/Etch/DCAMDynamics). The reason some effects do work is because they are a different class of AU plugin called a AU FX which let the host handle their MIDI. For some reason one class needs audio running through it and the other doesn't.

Or so our programmers tell me :)

Try it.

Posted: Tue Mar 05, 2013 4:28 am
by __BT41__
Tried this out with both audio and instrument tracks. While I still have no success with the built in MIDI Learn function, I CAN successfully assign via Logic's controller assignment window.

While it would be easier if the MIDI Learn worked, this is not too bad.

Thanks for investigating.

B