Which updates for bfd 1.5 - Fxpansion.com

Forum

FXpansion Forum

Which updates for bfd 1.5

Support for BFD Premium Acoustic Drum Module

Moderators: Drew_fx, clare_fx, SKoT_FX, Steve_FX, john emrich, Mully_FX, mayur_FX, Angus_FX, Andreas_FX, Rory_FX, Rhi_FX, Paul_fx, Moderators

d.h.p
Posts: 1
Joined: Sun Nov 20, 2005 5:07 pm

Which updates for bfd 1.5

Postby d.h.p » Sat Mar 19, 2016 7:31 pm

Hi, I've been out of the recording game for 5 years, I've just had a new system built, the specs are; 480g ssd, 4tb 3.5" sata drive 7200, 16 g of ddr3 ram, intel i5 4690k 3.5ghz 1150 88w, windows 10 64 bit, Cubase 8.5 64 bit, Apollo twin uad external sound card. I've loaded bfd 1.5, but having checked the bfd updates, i'm unsure as to which one's to apply, should I just load the latest build, or do I have to load the updates sequentialy? Any help would be great. I have also loaded bfd2 into my system, it appears as a stand alone on my desktop, but I can't find it in Cubase vst instruments, again any help would be great, thanks again, d.h.p.

owen247
Posts: 6
Joined: Thu Jun 07, 2007 12:32 pm

Re: Which updates for bfd 1.5

Postby owen247 » Fri Oct 28, 2016 3:05 pm

Hi D.h.p.
I'm in a similar situation (just added a new post, which probably won;t get replied to, given how old BFD 1.5 is)
anyway, did you get it to work in the end anyway?
I know I probably added updates in the past on my old system but I can;t remember the process...


Return to “BFD”

Who is online

Users browsing this forum: No registered users and 2 guests