Geist2 and Logic Pro X - MIDI Channels in Logic not Triggering Appropriate Function - Fxpansion.com

Forum

FXpansion Forum

Geist2 and Logic Pro X - MIDI Channels in Logic not Triggering Appropriate Function

User and tech support forum for Geist 2.

Moderator: Moderators

axemn
Posts: 1
Joined: Sat Jan 17, 2015 8:55 pm

Geist2 and Logic Pro X - MIDI Channels in Logic not Triggering Appropriate Function

Postby axemn » Wed Oct 09, 2019 5:34 pm

Hi there,

I am trying to trigger the pads and patterns of the 8 different engines specifically in geist with my MIDI controller (in this case a prophet keyboard). I set the appropriate MIDI channel on the Prophet (ie MIDI channel 4 to trigger engine 4) and it works perfectly on standalone mode but in Logic Pro X there's some kind of setting routing everything to engine 1. I can see in my MIDI meter in Logic that channel 4 is being used but Geist doesn't respond accordingly.

Any Logic wiz out there know what setting I need to change?

fmc
Posts: 1
Joined: Sun Apr 08, 2018 10:36 pm

Re: Geist2 and Logic Pro X - MIDI Channels in Logic not Triggering Appropriate Function

Postby fmc » Fri Oct 11, 2019 5:10 pm

If you open the track inspector in Logic (upper left corner, the icon is the letter "i" in a circle), under the track section there is an option to change the midi channel. Does that work?

djthermal
Posts: 3
Joined: Fri Dec 30, 2011 2:25 pm

Re: Geist2 and Logic Pro X - MIDI Channels in Logic not Triggering Appropriate Function

Postby djthermal » Fri Nov 08, 2019 3:28 pm

fmc is most likely correct, you probably have the midi channel on the Geist track (the track with Geist instantiated on it) set to "1". Make sure it is set to "All".

The channel setting is useful to force incoming MIDI into a specific channel regardless of the channel(s) it originally has. I use this in my setup for all my monotimbral instruments so that I can arm that track and play any of my controllers without having to set them to the same MIDI channel as the receiving instrument is set to (on the hardware).

But for multitimbral instruments like Geist, I set the MIDI receive channel in Logic to "All" and set the channel I want to control, on my controller keyboard.


Return to “Geist2”

Who is online

Users browsing this forum: No registered users and 3 guests